Professional UI Solutions
Site Map   /  Register


Please Log In to post a new message or reply to an existing one. If you are not registered, please register.

NOTE: Some forums may be read-only if you are not currently subscribed to our technical support services.

Forums » Prof-UIS General Discussion » Update 2.82 to 2.83 Collapse All
Subject Author Date
Developer NCS Jul 20, 2008 - 10:03 PM

<style type="text/css"></style>

Hi Prof-UI team!

We purchased Prof-UI 2.82 license for MFC and we’re using it. It’s very good, however in the process of use we detects a number of error in version Prof-UI 2.82 example as:

1.when we use RibbonBar in order to design MDI application, if click minimize and restore RibbonBar MDI, we dectected that RibbonbarMDI’s icons look askew in comparison with starting point.

2. We want to add dynamically ribbonpage at run time. We created a button that when click the button, a ribbonpage is added RibbonBar(This ribbonpage contains some buttons). But A number of buttons in the ribbonpage is focused in the run time create

3.We want to create a MDI application includes many childfrm and when click childfrm’s maximize button we want to be showed minimize, maximize, close button the next RightButtonsCollection like Microsoft Excel 2007.

4. Some features that we need are not supported yet in version 2.82


For these above reasons we decide to upgrade version Prof-UI from 2.82 fo 2.83. How to upgrade Prof-UI version 2.83 ? This upgrade is free or purchase ? How much If we have to purchase?

We desire to have answer soon from you.

Thanks !

Technical Support Jul 23, 2008 - 10:21 AM

We fixed the incorrect ribbon button layout (1) and [_][o][x] button (3) problems in v.2.83. If you need to change the ribbon layout (add/remove tab pages, button groups, individual buttons), you should re-construct the ribbon command tree and re-assign it to the ribbon bar control. Please let us know which features you need in the ribbon control. To upgrade from 2.82 to 2.83, just download 2.83, uninstall 2.82, install 2.83 and rebuild your project. You can download 2.83 if you have a valid subscription.