Professional UI Solutions
Site Map   /  Register


Please Log In to post a new message or reply to an existing one. If you are not registered, please register.

NOTE: Some forums may be read-only if you are not currently subscribed to our technical support services.

Forums » Prof-UIS General Discussion » Popup menu text doesn't show up Collapse All
Subject Author Date
Helen Lee Jun 24, 2011 - 3:19 AM


Could you tell me what I need to do to make the popup menu text to show up?  All the subitem’s text shows up, but not the popup text which leads to the subitems.  I’m certain that the menu resource is setup correctly, because I can see the text for both popup and the menuitems under the popup.

For example:




     --Menu3 (<--- this popup text does not show up)






Helen Lee Jul 6, 2011 - 10:42 AM

I sent it again. Are you able to receive it this time?

Helen Lee Jul 4, 2011 - 10:55 PM

I have sent the test project again.  When I click on the submenu item, it doesn’t trigger the method for that item.  Would you please take a look?


Technical Support Jul 5, 2011 - 8:27 AM

We didn’t receive any e-mails from you yet.

Technical Support Jul 7, 2011 - 1:04 PM

We compiled and run your app successfully. We can click on any menu items at the first and second levels. Some of them cause assertion failures, some of them display message boxes, and the about command displays the about dialog. Please provide us with more details about which item should we click and what should we expect from it?

Helen Lee Jul 8, 2011 - 10:39 AM

I cleaned up the test project some more to show you the problem that I’m encountering.  Details are in the e-mail.

Please let me know if you didn’t receive it.

Thank you for your help~


Technical Support Jul 8, 2011 - 10:43 AM

Dear Helen,
Please find the following line in the resource.h file in your project:

#define ID_TEST_SUBMENU1                61501

And replace it with the following:
#define ID_TEST_SUBMENU1                21501

The 61501 value is in range of system command identifiers such as SC_MAXIMIZE. Please use identifiers in some other range. For instance . . . 1000 . . . 20000. Prof-UIS uses range 29000 . . . 31000.

Helen Lee Jul 8, 2011 - 11:19 AM


That fixed it. Thanks a lot!!!  I’m learning something new everyday  !


Helen Lee Jul 5, 2011 - 6:36 PM


I sent it on 7/4 Subject: Submenu item doesn’t respond to click.  I have sent it again, please let me know if you don’t receive it.



Technical Support Jul 6, 2011 - 6:06 AM

Dear Helen, we received the following mail from mail server:

The message "Submenu item doesn’t respond to click" from your-e-mail-address-here contained a virus or a suspicious attachment. It was therefore not fetched from your account our-e-mail-address-here and has been left on the server.

Could you please re-send your e-mail?

Technical Support Jun 24, 2011 - 12:03 PM

Text, which is part of any menu item should be displayed without any effort from you. You don’t have to perform any specific actions.
Could you show us the source code which initializes and shows a popup menu.

Helen Lee Jun 26, 2011 - 2:45 AM

Here’s what I have to initialize the popup menu in InitInstance :

 CFTPClientApp *pApp = (CFTPClientApp *)AfxGetApp();

  m_pDocTemplate = new CMultiDocTemplate(



  RUNTIME_CLASS(CChildFrame), // custom MDI child frame


Here’s the code to create the menu:

 CWinApp * pApp = ::AfxGetApp();

 VERIFY(g_CmdManager->ProfileSetup(pApp->m_pszProfileName, GetSafeHwnd()));

 VERIFY(g_CmdManager->UpdateFromMenu(pApp->m_pszProfileName, IDR_DELUXEPROTYPE));



        TRACE0("Failed to create menubar\n");

        return -1;      // failed to create



 if( !CExtControlBar::FrameEnableDocking(this) )



  return -1;




If I comment out the menubar creation and revert back to the default menu, the text for the popup menu works correctly.

Please help, I have successfully switched all other toolbar controls to Prof-UIS, but I just can’t get this menu text to show up!!



Technical Support Jun 26, 2011 - 9:55 AM

The initialization code is OK. You can find the same code in the MDIDOCVIEW application where all menu items display text without problems. This means the real source of the problem is hidden in somewhere else what we didn’t discuss yet. Could you send us a test project which reproduce this problem?

Helen Lee Jun 27, 2011 - 9:04 PM

I received your fixed code.  It works now, thank you very much, you guys are very helpful!