Professional UI Solutions
Site Map   /  Register


Please Log In to post a new message or reply to an existing one. If you are not registered, please register.

NOTE: Some forums may be read-only if you are not currently subscribed to our technical support services.

Forums » Prof-UIS Tech Support » Grid in Dialog Has a Bunch of Blank Space Collapse All
Subject Author Date
Bill Olson Dec 6, 2011 - 3:37 AM

I’ve got another problem with my dialog with a CExtGridWnd on it.

I had a problem getting a continuous string of text to wrap and the rows to size the height properly.  I’ve solved that problem, but now if a cell has text with multiple lines formatted with \r\n for line breaks, the text doesn’t display correctly.  The text ends up cutoff in the cell with a bunch of blank lines at the bottom.  If I resize the cell enough, I can see all the data, but the size of the blank area at the bottom of the cell increases as I make it bigger.

The settings for the grid are:







Each cell is formatted when data is inserted with:



This looks like some sort of setting of the style flags, but so far I haven’t been able to figure out the magic combination.

I have screen shots showing the problem, but I don’t see where I can directly upload an image here.


Bill Olson Dec 8, 2011 - 7:45 PM

I see what I did.  I accidentally put __EGCS_EX_MULTILINE_TEXT in the ModifyStyle function, not the ModifyStyleEx function.  Looking at the definition, the __EGCS_BUTTON_UPDOWN style and the MULTILINE style have the same value.  For some reason putting that style in the ModifyStyle function fixed the blank line issue, which I don’t think it should have.



Technical Support Dec 8, 2011 - 8:57 AM

You should remove the __EGCS_BUTTON_UPDOWN basic grid cell style.

Technical Support Dec 6, 2011 - 12:36 PM

You specified the __EGCS_EX_WRAP_TEXT extended style and forgot to specify the __EGCS_EX_MULTILINE_TEXT extended style. Additionally, the __EGCS_TEXT_ELLIPSIS basic style does not work with the __EGCS_EX_MULTILINE_TEXT extended style.

Bill Olson Dec 6, 2011 - 11:43 PM

I posted a replay, but it appears to have disappeared...

Adding __EGCS_EX_MULITLINE_TEXT worked, but now I have up and down arrow spinner controls in every grid box.  I experimented taking out the new flag and the spinner controls went away, so it is tied to the MULITLINE_TEXT flag.  How do I get rid of these spinners?